Mercedes-Benz Metris Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
483 Posts
Discussion Starter #1
Whoa is me. While adding some equipment to my Cargo van I removed the front passenger seat. On the third day I needed to get some other parts and haul some things so I started up and drove short distance. Now I have 'airbag light' with 'Requires Service' warning. Dealer says they need to do a complete diag scan. Crap! Anyone know other options besides dealer to reset it?
 

·
Registered
Joined
·
76 Posts
I've tried the available code readers and dont support the Metris.
Dealer wants $175 to reset mine. I'll live with the warnign light for a while.

They claim they cannot reset it without performing a full diag on the system.
 

·
Registered
Joined
·
939 Posts
They want one hour of labor to hook up the cord, ran codes and clear them. $175 is high too...
Edit: post 500
 

·
Registered
Joined
·
483 Posts
Discussion Starter #5 (Edited)

·
Registered
Joined
·
483 Posts
Discussion Starter #6
I've tried the available code readers and dont support the Metris.
Dealer wants $175 to reset mine. I'll live with the warnign light for a while.

They claim they cannot reset it without performing a full diag on the system.
I got $140-ish from the dealer I purchased from. Said same thing. Need to run full diag to reset.

So pissed because on Day 1 I unhooked it I said to myself to maybe not turn the key without seat plugged in...but by Day 3 It just slipped my mind that the harness was unplugged. Yes, I saw that I had no passenger seat, but thats all that came across my mind at the time.

The red airbag light is one thing, but I have the "4.2" Pixel Matrix Display" upgrade in the instrument panel and upon start up I get the big letters warning of Requires Service...have to click OK to see any other info with every start.

Just don't understand how a full diag is needed when I explained what happen. Just reset it...IF the warning comes back...then we can talk full diag! :|
 

·
Registered
Joined
·
248 Posts
I got $140-ish from the dealer I purchased from. Said same thing. Need to run full diag to reset.

So pissed because on Day 1 I unhooked it I said to myself to maybe not turn the key without seat plugged in...but by Day 3 It just slipped my mind that the harness was unplugged. Yes, I saw that I had no passenger seat, but thats all that came across my mind at the time.

The red airbag light is one thing, but I have the "4.2" Pixel Matrix Display" upgrade in the instrument panel and upon start up I get the big letters warning of Requires Service...have to click OK to see any other info with every start.

Just don't understand how a full diag is needed when I explained what happen. Just reset it...IF the warning comes back...then we can talk full diag! :|
Have you tried the Autozone? The offer free scan and resets
 

·
Registered
Joined
·
147 Posts
I wonder if OBDELEVEN, would be able to clear the codes?
I have an Audi TTS and OBDELEVEN was recommended to clear an annoying prompt.
The unit doesn't cost too much, but you have to buy a subscription in order to clear codes. All in all, it would cost about $100 bucks.
HTH
Bob
 

·
Registered
Joined
·
483 Posts
Discussion Starter #13
I wonder if OBDELEVEN, would be able to clear the codes?
I have an Audi TTS and OBDELEVEN was recommended to clear an annoying prompt.
The unit doesn't cost too much, but you have to buy a subscription in order to clear codes. All in all, it would cost about $100 bucks.
HTH
Bob
Doesn't list Metris or any Mercedes as compatible.
 

·
Registered
Joined
·
483 Posts
Discussion Starter #14
Have you tried the Autozone? The offer free scan and resets
No I haven't. I doubt the reset, but won't hurt to ask. Definitely not getting my hopes up. lol
 

·
Registered
Joined
·
483 Posts
Discussion Starter #15
Whenever a Metris Do's and Don'ts sticky thread is made. I'll be SURE to add this: Don't unplug ANY harness and start the vehicle.
 
  • Like
Reactions: DerDichter

·
Registered
Joined
·
151 Posts
Crap!! I just had the same thing happen when I removed my seat to test fit a swivel base (which does not fit as-is). I made sure to put everything back before starting the engine. I was told to disconnect the battery before unplugging anything, but I thought that was a little over cautious.

DON'T UNPLUG ANYTHING WITHOUT FIRST DISCONNECTING THE BATTERY!

I need to go back to the dealer next week for them to fix my door sill under warranty. I wonder if they would reset the fault too.
 

·
Registered
Joined
·
292 Posts
I have the same problem with the air bag lights after removing both of my front seats. So far I'm just living with it since I know all that I did was disconnect the cannon plug. I still need to install swivel seats in my van so no point in dealing with the light until that is complete.

Thus far I have not found an OBD scanner that works on the Metris.
 

·
Registered
Joined
·
483 Posts
Discussion Starter #19
NECRO!
Just so it's fresh in everyone's brain. Don't unplug any harnesses without first disconnecting the negative battery terminal. Or it could cost you $140-175 at the dealer for a diagnostic test to reset.
I just dealt with the dash light on until my next major service (30k Transmission Fluid Flush/Filter) and the SA threw me a bone and had the tech do the diag test and reset it at no cost. #LessonLearned
 
1 - 19 of 19 Posts
Top