Mercedes-Benz Metris Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
258 Posts
All of the Benzes that I have owned previously that had FSS, had the reset procedure in the manual. The Metris gives the same answer that Greenmanedlion gave, which is probably not what FlyDSky was looking for. I have found the procedure for resetting the service for Sprinter and it might be a place to start. I have not tried it, yet.
 

·
Registered
Joined
·
939 Posts
Key on 1, on mileage, press and hold answer then hold OK. Scroll to service reset, then OK. (This is all by memory, will update when I'm back at a benz)
 

·
Registered
Joined
·
258 Posts
reset instructions

I have attached the reset instructions that were sent to me. Please note that the first set, for vehicles without steering wheel buttons, is OK but the second set were not scanned properly. I think they may be enough but have contacted my source for a better scan and will post it when I receive it.
 

Attachments

·
Registered
Joined
·
89 Posts
I finally got my service message to reset. Here's how:
Put the key to position 2.
Use arrow keys so it shows how many miles you've driven (part of the first trip series of options).
Hit the phone key and hold it down.
Immediately hit the OK button and hold it down as well.
In 10 seconds up comes a menu to follow to register that you've done the oil change/service which resets ASSYST Plus to 14,900 miles.
This video explains it:

Based on the written guidance I was doing a bunch of things similar to that, but not quite it.
 

·
Registered
Joined
·
258 Posts
Thanks, tcp, for posting this. It certainly simplifies the procedure. Mine is not due for another 7 months but I do want to know how to do it when the time comes.
 

·
Registered
Joined
·
258 Posts
Just did the A service following the service sheet that RobbMeex posted and reset the service reminder following Rob and tcp's posts and it worked fine. Thank you both!

Interesting finds: The spare was at 35 psi and the filter element was really hard to slide off the holder
 

·
Registered
Joined
·
184 Posts
Just did the A service following the service sheet that RobbMeex posted and reset the service reminder following Rob and tcp's posts and it worked fine. Thank you both!

Interesting finds: The spare was at 35 psi and the filter element was really hard to slide off the holder
The filter comes off in a surprising fashion...lol, I thought for sure I broke it!
 

·
Registered
Joined
·
939 Posts
We have had MANY problems getting filter #1 off. After that, they remove much easier.

I take my pocket screwdriver and break the edge of the filter in 2 places and it slides right off.
 
1 - 15 of 15 Posts
Top