Mercedes-Benz Metris Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
My van starts and my gear shift doesn't change from Park to drive. It's been happening quite a few times. After few hours it works. is this the quality of Mercedes? I present this issue to dealer. They say it need to be looked at . It take few days. I asked for dealer to provide me loaner, they said they will let me know when they get loaner. After few months I haven't get any information. Is the service Mercedes provide to the customer?
 

·
Registered
Joined
·
59 Posts
I have has nothing but the best with with Mercedes Benz of Naples Florida. They gave me a brand new GLC300 last time. I put 2,000 miles in 1 week while while I had it. Due to a pre planned road trip... They said no worries and gave me back my van fully detailed. Maybe you need to try a different dealer if you have more choices. Oh yeah van was in for a passenger side sliding door. Bad lock actuator.
 

·
Registered
Joined
·
397 Posts
If a dealer is giving poor service you should call MBUSA/MB Vans and complain. MB goes after dealers providing poor levels of service. I have not heard of many issues with the 7GTronic shift lever. Does the vehicle give any error message when you attempt to select drive or reverse? Does it go out of park into neutral? If there's no message at all I suspect its an issue with the actual switch/lever as the computer in the vehicle would give an alert or complaint if it was receiving the shift request and could not complete the request.
 
  • Like
Reactions: RobbMeeX

·
Registered
Joined
·
3 Posts
Similar problem

Hi I had a similar scenario and it turned out the chassis CAN wiring harness was routed incorrectly and shorted out. I've had it in the shop 3x for the same issue. First time it was the parking/drive shift operation in which it said it couldn't shift but physically it was actually shifting into all gears (very scary to drive BTW). Dealer first replaced the ignition control which was a waste of time. 2nd they found the damaged wiring harness routed around the parking brake which causes a short. My whole van was lit up with errors. 3rd time and 30 days/3000miles later, the same harness was shorting out where it routes to the door from a "pinch." My dealer is also the biggest PITA and never wants to work with me. They pretty much look at us and treat the Metris owner like a piece of smelly garbage that hasn't been taken out in a week. I have very limited options for dealers and never would have bought the Metris if I knew MBvan dealers were so awful (compared to the regular passenger car Benz dealers).
 
1 - 4 of 4 Posts
Top