Mercedes-Benz Metris Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I just had my 2016 metris passenger inspected (Tx). And it was failed because apparently they assessed the engine check light to not be working.

Now I'm seeing the below, and want to confirm if this is normal or not:

Key in off position (0) - no lights on dash
Key turned clockwise, one click, radio on (1) - engine check light off <--
Key turned clockwise, second click, ignition on (2) - engine check light on
Key turned clockwise to start engine (3) - engine check light off
Key turned anti-clockwise (1) - engine check light on
Key turned anti-clockwise to off position (0) - engine check light off
Key turned clockwise, one click, radio on (1) - engine check light on <--

You'll notice that if you do the steps in sequence, within a short period of time, engine check light is on when key is in position (1) at the end of these steps.

If I instead wait a period of time with the key in the off position (0) and then key is turned to position (1), engine check light is off.

I believe the discrepancy between engine check light being on in position (1) is what has flagged as a fail. But I would imagine this to be normal behavior.

Thoughts?
 

·
Registered
Joined
·
401 Posts
Sounds normal to me....why are they looking at the lights, why don't they just plug in a basic code reader and verify it has no faults? Sounds like the inspection people are a few geese short of a gaggle....
 
1 - 3 of 3 Posts
Top