Mercedes-Benz Metris Forum banner
1 - 8 of 8 Posts

·
Registered
2019 Passenger
Joined
·
1,339 Posts
I am fond of Ram brand mounts. If you aren't put off by the truly utilitarian look of them... They function very well. I mount them with screws and such, but they do have products that can mount in drink holders and on glass.

https://www.rammount.com/part/RAP-299-3-UN10U

If you like magnetic mounts then there is an endless pool of options on Amazon. You may want to start our with something temporary mount to find the location that works best for you.
 

·
Registered
Joined
·
81 Posts
I am using something similar to this:

[ame]https://www.amazon.com/WizGear-Universal-Swift-Snap-Technology-Smartphones/dp/B00PGJWYJ0[/ame]

I notice that the top few grids of the central air vent are fixed and attached it there. It works well with my phone but I won't recommend it if you have a plus sized phone.
 

·
Registered
Joined
·
5 Posts
I've been using Pro-clip mounts for my last several vehicles. They sell the car mount separately from the phone mount, so you only replace half of it when you upgrade either device. I just installed this one, fits perfectly. I guess I can't post links yet, but if you google, you'll find it.
 

·
Registered
Joined
·
161 Posts
I just installed the Pro-Clip adapter too. Fits over the phone holder cubby to the left of the center instruments and has mounting holes for their separately sold phone holders and could probably also be used with other phone holders. Doesn't block the vent and is way more secure!
 

·
Registered
2016 Metris Cargo
Joined
·
22 Posts
I also installed the Pro-Clip phone holder (for my Android phone) and then used their magnetic mount (adding magnets to the back of my phone case) and connected it to the USB outlet at the back of the small cubby just to the right of the steering wheel.

At first I loved it since the clip was custom designed for the Metris - although I did need to be careful to not knock it off the mount since the magnets are not super strong and my phone is fairly heavy.

But a few times, it wouldn't charge - no matter how carefully I attempted to align the phone on the holder. Of course, the times it wouldn't charge was when my battery was low and I really needed it to get directions. I'm not sure why it intermittently won't charge and was wondering if anyone else has experienced the same thing. I don't know if its related to load on the car battery and it somehow shuts off power to the USB port? I had the engine running so I would think with the engine running their should always be enough power for an additional small load like a phone charger.
 
1 - 8 of 8 Posts
Top