Mercedes-Benz Metris Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I have the automatic climate control option with high output AC since I have the passenger version. The problem I have with the climate control (Either Air conditioning or heating) is that it seems it only has two settings; full temp cold or full temp hot. This is irrespective of the fan/blower speed by the way.

Keep in mind the climate control has the following temperature range; LO, 60-80 and HI. I am also describing my issue with the automatic climate control turned off and operating it manually.

In the winter, it will blow out full temp hot at 60. By full temp hot I mean the heat comes out as if I had it turned all the way up to HI. Only when I then put it into LO will it then come out less hot but then it comes out full temp cold. Even adjusting the heat setting to anywhere in the 60-80 range it comes out full temp hot. Nothing in between.

Then in the summer, it’s the opposite. It will blow out full temp cold all the way up to 77. By full temp cold I mean the cold comes out as if I had it turned all the way down to LO. Only when I then put it into about 77 will it then come out less cold but then it comes out full temp hot. Even adjusting the cold setting to anywhere in the 60-80 range it comes out full temp cold. Nothing in between.

Anyone come across this? I have the 2018 Metris Passenger.
 

·
Registered
Joined
·
8 Posts
I am experiencing the same thing in my 2019. I end up having to turn down the fan. Have not taken it in to dealer. Only a/c...have not tried heat b/c van is new.
 

·
Registered
Joined
·
147 Posts
My 2017 acts the same way. I have to either dial up/down the temp to within 2-3 degrees of the outside temp in order to get the fan to blow at something less than full blast.
The Metris is the only vehicle I have owned, that behaves this way.
Bob
 

·
Registered
Joined
·
70 Posts
On my old Eurovan there was a small fan that would draw air over the indoor temperature sensor. If the fan was out it would exhibit odd behavior, similar to what is being described. The fix was to clean the dirt/dust out of the fan. Have no idea if this relates in any way on a Metris.
 
1 - 4 of 4 Posts
Top