Mercedes-Benz Metris Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi all,

A few months ago I left the key in the ignition which resulted in the battery drained and I couldn't start the car. I have a charger with a function that allows me to start the car however that didn't work - it almost turned over...
I got the car jumped but after that my blind spot alert didn't work. After I drive for a few mins I get the alert that the blind spot isn't working. The audio/phone controls on the wheel don't work either. The controls on the left side work - the ones where I access the car details etc.
I checked fuses but I can't find any that are broken.

Any help/comment are appreciated.
Thank you!
 

·
Registered
Joined
·
2 Posts
Hi all,

A few months ago I left the key in the ignition which resulted in the battery drained and I couldn't start the car. I have a charger with a function that allows me to start the car however that didn't work - it almost turned over...
I got the car jumped but after that my blind spot alert didn't work. After I drive for a few mins I get the alert that the blind spot isn't working. The audio/phone controls on the wheel don't work either. The controls on the left side work - the ones where I access the car details etc.
I checked fuses but I can't find any that are broken.

Any help/comment are appreciated.
Thank you!
 

·
Registered
Joined
·
291 Posts
Since it's a metris. I would do a reboot as in disconnecting the main battery for a few minutes and then reconnecting.
 
1 - 5 of 5 Posts
Top