Mercedes-Benz Metris Forum banner
21 - 40 of 59 Posts

·
Registered
2021 passenger
Joined
·
5 Posts
My 70 plate 447 crew van with audio 30 went in today because CarPlay drops out regularly same issues as above doesn’t carry on music after calls drops out freezes on iPhone 12plus , it had latest update on both phone and van (twice to double check )at mb dealer still no joy, new cables and all works fine in my other car play vehicles resettled everything started again , they where playing innocent like they hadn’t heard of it then as I got more persistent magically started suggesting there was other vans with issues , I’m still in first couple of weeks of ownership so I’m being fairly persistent to get this sorted or compensated to cover costs of changing unit out … does anybody know of anyone that has a perfectly working audio 30 /40?
Mine is still working since the update… hope it stays that way!
 

·
Registered
Joined
·
1 Posts
I have the same issue with My Vito which I bought new 1 month ago with Audio 40. I spoke to my dealer and they updated. and it's better but still doing it. What is even more fustrating is that you have to turn off the vehicle and go out of range for 5-10 mins for it to reboot the media player otherwise it instantly restarts with the same problem. The dealer said he has looked into it and MB are aware and it is a connectivity issue with iPhone 12's and said MB are working on a fix. He said he will let me know but wont hold my breath. I have to say it is very fustrating. Can I suggest the forum is reheaded Audio 30 and 40 car play issues
 

·
Registered
Joined
·
17 Posts
Same for me with a new 447 and audio 40. Went back to the dealer last weekend and they have escalated to Mercedes and am awaiting reply. It may be that the Audio 30/40 is such an old model that it cannot cope with the speeds of modern phones. The Vito 447 is not even on the approved list from Apple for carplay.
Best of luck.
 

·
Registered
2021 Getaway
Joined
·
25 Posts
I submitted a gripe to MB and received a call from a very pleasant customer service person. Unfortunately she was very pleasantly unable to provide any options or recourse for the connectivity issue (2021 Getaway). I also have an issue with my backup camera on my 2021 GLC (recall fix "pending" - which means unavailable and no ETA) which she was unable to provide help with. Anyone know of the MB escalation route?
 

·
Registered
Joined
·
17 Posts
Hi Nancy
This is a worldwide issue, Mercedes are no longer using the Audio 40 I have been told. Letter before action, in the UK, as the unit is not fit for purpose. In the UK some dealers are replacing Audio 40 with aftermarket product at dealers expense. Mercedes are not what they used to be, will never buy another one, customer service is shocking.
 

·
Registered
2021 Getaway
Joined
·
25 Posts
This is a worldwide issue, Mercedes are no longer using the Audio 40 I have been told. Letter before action, in the UK, as the unit is not fit for purpose. In the UK some dealers are replacing Audio 40 with aftermarket product at dealers expense.
Would like to know what head unit and wiring harness is compatible with 2021 Metris. Maybe MB USA will do something similar (doubtful)...
 

·
Registered
Joined
·
4 Posts
I’m going to go turbo this week And kick off they are shrugging off the fact the stereos are really poor it’s an expensive van and sold with this feature so should be reliable and working anybody from this group in Dorset ??
 

·
Registered
Joined
·
17 Posts
I’m in Southampton with same issue.
Ask them for a written report on the issues you are having with your radio Including any faults and physically show them if needed.
Tell them you would like it repaired or replaced with after market unit if in warranty.
If no go then send the dealer a “letter before action” then if still no movement take them to small claims court as it is not as described or fit for purpose. I have not got quite that far yet but definitely will.
Best of luck!
 

·
Registered
Joined
·
4 Posts
I think maybe both our vans where in Marshall’s just over a week ago ??? I bought it there just over a month ago and they knew nothing of any issues magically there are a few cases .. now 🤦🏽
 

·
Registered
Joined
·
17 Posts
I think maybe both our vans where in Marshall’s just over a week ago ??? I bought it there just over a month ago and they knew nothing of any issues magically there are a few cases .. now 🤦🏽
Yes mine has been in at Marshalls 3 times now but I have recently been speaking with their tech expert who agreed there is an issue and he is approaching Mercedes about my faulty Audio 40 which he could not get working properly on his phone and active park assist being faulty/disabled. If not sorted with Audio 40 then my legal case is already built and waiting to go. Good dealerships up and down the country are changing these to after market ones, I wonder how Marshalls will proceed and this will depend whether they are a good dealership or not.
 

·
Registered
2019 Passenger
Joined
·
1,591 Posts
The aftermarket units are pretty nice and a worthy upgrade. Personally, I wouldn't spend my time on the issue. Wireless carplay and android auto on other units is totally worth it. Saves a lot of cable fiddling multiple times a day.
 

·
Registered
Metris Cargo 135 2020
Joined
·
647 Posts
How would legal action / small claims court help to get MB to fix the radio faster?
What is the exact goal you have in mind?

And, might a judge not simply brush it off and say sounds like MB is already working on it, wait for the fix?

Compatibility lists are outdated the moment they are printed, they are rarely updated and tech changes fast … sometimes too fast, so I would think whatever references an iPhone 7 is just some ancient relic that a search turned up, because of lack of a newer document of the kind.

Between different large corporations, official compatibility lists are very laggy … if it were officially listed as incompatible, now that would be alarming. A certain vehicle model not being on the list, with new models coming out weekly, systems being upgraded in existing model lines, … I don’t think Apple is very worried about that list.

We all know MB puts some of their old stock tech in the Vito & Metris vans, because they are primarily work vans, creature comforts are deemed less important, keep cost down, update cycles, … so the vans - unfortunately enough - lag behind in tech. But, even with the latest models of any brand vehicle, their radios and then any given phone: bugs will happen … even if manufacturers had their own brand of smartphones it would be a frustrating experience.

And then we get to Pioneer, who makes these head units for MB, right?

So, there are a lot of gears and wheels that need to turn between three major corporations to identify the root cause and remedy.

And for all the finger pointing at MB, I for one would not be surprised to see an operating system update on a phone that says, improves compatibility with CarPlay. When one looks at patch notes for software, phones, all kinds of stuff needs sorting all the time. Worst case scenario it could be car radio update, CarPlay update, phone update.

In the interest of troubleshooting:

Which brand and model phone is everybody using?

What is the exact issue you are seeing?

New radio firmware applied?
 

·
Registered
Joined
·
4 Posts
Yes mine has been in at Marshalls 3 times now but I have recently been speaking with their tech expert who agreed there is an issue and he is approaching Mercedes about my faulty Audio 40 which he could not get working properly on his phone and active park assist being faulty/disabled. If not sorted with Audio 40 then my legal case is already built and waiting to go. Good dealerships up and down the country are changing these to after market ones, I wonder how Marshalls will proceed and this will depend whether they are a good dealership or not.
They have been pretty helpful with me I know it’s none of their faults … I have a couple of issues also that they are trying to sort also so not annoyed with them as a dealer but they do need to sort a solution for the head units
 

·
Registered
Joined
·
2 Posts
Mine is still working since the update… hope it stays that way!
I have my 2021 Metris service with the same issue that everyone is experiencing here. The Technician updated the firmware on the radio and tested it with his iPhone 11 and it works perfectly. When I got my Metris back and hookup with my IPhone 12 same problem existed. The MB dealer told me that they will have to find a fix for the IPhone 12 but for now he said to use an old IPhone and just have it link to a hot spot for internet. Now I still have my iPhone 10 and it works well. I think if you have the firmware updated in your vehicle, it will work fine so long as it’s not a IPhone 12.
 

·
Registered
Joined
·
3 Posts
Hey all,

Just recently picked up my 2021 Cargo 135. Really enjoying it and going slowly through some minor upgrades.

I know from the build sheet it came with Audio 30 unit with bluetooth and carplay. The carplay must be plugged into the specified usb. I can get carplay to work properly for a few minutes, then it loses connection. Sometimes plugging the phone back in will work, but then it will again lose connection again, repeating over and over.

I have tried with/without bluetooth, Apple branded and 3rd party cables, resetting the Audio 30 unit and phone yet nothing prevents it from constantly disconnecting. Another issue is sometimes when I plug the phone in to the usb cord i get a message on the screen saying "There was a problem initializing the apple device".

Has anyone else run into this issue? Any solutions aside from driving back to the dealership and dealing with service?

Thanks, Kevin
 

·
Registered
Joined
·
3 Posts
i discovered that the order in which you plug things in seems to matter. First unplug the cable from phone and USB pairing socket. Then turn on both iPhone and Merc ignition. Set the Audio 30 to Home. Next plug in the USB into the pairing socket. Finally plug in the Lightning connector into the iPhone. After a few seconds, you should see CarPlay connected. In any other sequence, I would get the same problem as you are experiencing.
 

·
Registered
Joined
·
3 Posts
i discovered that the order in which you plug things in seems to matter. First unplug the cable from phone and USB pairing socket. Then turn on both iPhone and Merc ignition. Set the Audio 30 to Home. Next plug in the USB into the pairing socket. Finally plug in the Lightning connector into the iPhone. After a few seconds, you should see CarPlay connected. In any other sequence, I would get the same problem as you are experiencing.
But it ain’t foolproof. After a few weeks of flawless working, today my iPhone won’t share its address book, & I’m getting the same problem no matter what sequence I plug in the cables!
 

·
Registered
Joined
·
17 Posts
Hey all,

Just recently picked up my 2021 Cargo 135. Really enjoying it and going slowly through some minor upgrades.

I know from the build sheet it came with Audio 30 unit with bluetooth and carplay. The carplay must be plugged into the specified usb. I can get carplay to work properly for a few minutes, then it loses connection. Sometimes plugging the phone back in will work, but then it will again lose connection again, repeating over and over.

I have tried with/without bluetooth, Apple branded and 3rd party cables, resetting the Audio 30 unit and phone yet nothing prevents it from constantly disconnecting. Another issue is sometimes when I plug the phone in to the usb cord i get a message on the screen saying "There was a problem initializing the apple device".

Has anyone else run into this issue? Any solutions aside from driving back to the dealership and dealing with service?

Thanks, Kevin
Hi

basically Mercedes have been screwing people over these audio systems. They do not work as described and they do bot want to fix. Until the many people with this issue, me included, start taking legal action this will go on.
Mercedes have become a second rate manufacturer unfortunately.
 
21 - 40 of 59 Posts
Top