Mercedes-Benz Metris Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
Hello, my 2017 metris passenger van, 50k miles, zero problems with it-ok, I take that back, the rear washer fluid pump fitting broke, the dealer wanted $600 to repair and replace-I fixed myself with bonding the fitting that cracked haha. Anyway, got a light on instrument panel that comes and goes "AUXILIARY BATTERY MALFUNCTION"...not always on, but maybe half the time I drive. Any remedies for it? and please don't post "take it to a dealer", I am out of warranty and refuse to pay their prices for repair-I will assume its a aux battery is dead maybe? or some fuses?
 

·
Registered
Metris Cargo 135 2020
Joined
·
113 Posts
My 2020 135 with start/stop has an extra battery under the passenger seat. I don't know if that's what' meant with the aux battery?
I have a flap facing outwards in my cargo seat bases. I think in the passenger version it is flap to access from the rear.
Anyhow, in my metris the extra one under the seat is is pretty sizable.
There is room and a wire in my driver seat base for a third battery.

On my ML350, when it was maybe 7 years old (?), I got a battery fail / replace notification. The vehicle had under the passenger seat, the oversized main battery and a tiny 12v aux one - like kbcool showed - hidden behind it. One could not see it and certainly not access it unless the big one was pulled out. ( or maybe dealers can if they take the whole seat out )

I recall something about the sedans having these typically near a fuse panel in either the trunk or below the passenger glove box area ... but it can also be in the driver side outside facing dash panel ... that's where the one in my wife's car was hidden (despite the dealer insisting it was in the trunk).
 
1 - 8 of 8 Posts
Top